;) This forum is the property of Proton software developers

Main Menu

MCC plugin

Started by Giuseppe MPO, Jan 14, 2022, 06:07 PM

Previous topic - Next topic

Giuseppe MPO

I have installed the new MPLAB IDE version.6.0 and plugin MCC, which for this version is 5.1.0,
is a plugin that I find very convenient for setting the various registers for the calculation of times, timers, interrupts, etc. etc.
It is often convenient for me to understand the functioning of new PICs that I do not know.
The problem is that with this I tried to do a test project and it tells me that the PIC18F25K22, which I use a lot as a generic PIC,
is not supported by this version.
Of course it is not a new PIC but not very old or obsolete either. but does Microchip support customers like this?
Does it make the new models and abandon the ones that are not yet old?
A complete disappointment.

Stephen Moss

I assume you mean MPLABX IDE, rather than MPLAB IDE which as I recall the last version was something like 8.9.
Does it give a reason why that device is not supported or is it just not listed in which case it could just be an error. If a reason is given then it is possible just dropping the relevant files for the device into the appropriate folder to restore support may not work but it is always worth trying.  ​

Look for the PIC file (PIC18F25K22.PIC) in your equivalent of C:\Program Files\Microchip\MPLABX\v5_45\packs\Microchip\PIC18F-K_DFP\1.4.87\edc, if it is there then I would think it the IDE should still support it and it should support is as it appears to still be in production.

Giuseppe MPO

Quote from: Stephen Moss on Jan 17, 2022, 10:13 AMI assume you mean MPLABX IDE.
Yes, i meant MPLABX IDE ver.6.00 the latest version.
The PIC I am talking about, the PIC18F25K22, is still in production and is still fully supported by MPLAX IDE, the problem is on the MCC plugin (Mplab Code Configurator),
which is the only thing I use, it is the plugin that tells me that it does not is more supported.

Giuseppe MPO

I solved it,
I installed the Classic version of the plugin.
Now works.